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Focus stacking for cataloguing, presentation, and 
identification of microfossils in marine sediments
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of microfossils in marine sediments; Geological Survey of Canada, Technical Note  11, 9  p.  
https://doi.org/10.4095/331355

Abstract: Microfossils represent an important part of studying past depositional environments and 
determining ages for the strata they are found within. The key to ascribing paleoenvironmental interpreta-
tions to the sediments in which a microfossil is found is accurate identification of the microfossil. A num-
ber of techniques can be used to identify microfossils, including ones that use key features, morphologies, 
and characteristics from imagery acquired using a scanning electron microscope. A low-cost, efficient 
alternative method is digital photography of optical microscope images. This technical note presents a 
method for acquiring photos of microfossils and two methods for compiling them into high-resolution 
images using focus stacking. The process is described in four main steps: image acquisition, exportation, 
focus stacking, and annotation.

Résumé : Les microfossiles constituent un élément important de l’étude des milieux de dépôt du passé 
et de la détermination de l’âge des strates dans lesquelles ils se trouvent. La condition fondamentale pour 
attribuer des interprétations paléoenvironnementales aux sédiments dans lesquels se trouve un microfos-
sile est l’identification précise du microfossile. Un certain nombre de techniques existent pour identifier 
les microfossiles, dont celles qui utilisent les principaux traits, les morphologies et les caractéristiques 
révélés par des images acquises au microscope électronique à balayage. Une méthode alternative peu 
coûteuse et efficace est la photographie numérique d’images au microscope optique. Cette note technique 
présente une méthode pour acquérir des photos de microfossiles et deux méthodes pour compiler celles-ci 
en images haute résolution à l’aide de l’empilement de mises au point. La façon de procéder comporte 
quatre étapes : l’acquisition d’images, l’exportation, l’empilement des mises au point et l’annotation.

Corresponding author: J.B.R. Eamer (jordan.eamer@nrcan-rncan.gc.ca)
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INTRODUCTION
Marine microfossils are organisms or skeletal elements 

that require a microscope for analysis or identification 
because of their small size (usually <1  mm) (Witkowski 
et al., 2015). They play an integral role in marine geology. 
They are used to correlate stratigraphic facies (e.g. Fensome 
et al., 2019), to provide the material necessary for absolute 
age determination (e.g. Lister et  al., 2015), for deriving 
paleoenvironmental indicators (e.g. Pieńkowski et al., 2013), 
for developing data on modern and ancient oceanographic 
processes (e.g. Bradley et  al., 2012) and on sedimentary 
processes (e.g. Mudie and Yanko-Hombach, 2019), and for 
geochemical methods such as isotopic studies (e.g. Bohaty 
et al., 2012), among other uses.

Developing useful data sets from microfossils extracted 
from a geological sample requires accurate identification of 
the taxonomy of the fossil. This is done using microscopy 
and, increasingly, using digital methods. With advances in 
technology related to microscopy and imagery, the digiti-
zation of microfossils viewed under an optical microscope 
(as opposed to images generated using a scanning electron 
microscope) enables researchers to share, publish, and dis-
cuss microfossils inexpensively and efficiently. Digitization 
has also enabled the development of efficient tomographic 
techniques for generating 3-D images from several 2-D opti-
cal images, important for deriving more information from a 
fossil (Sutton, 2008).

Improvements in image processing software, and the 
increasing ubiquity of software developed for this purpose, 
have led to opportunities to collect higher quality digital 
imagery from optical microscopes. In particular, adding a 
third dimension through serial focusing (Sutton, 2008) or 
focus stacking (e.g. Kibby, 2019) is a simple and effective 
way to produce ‘2.5-D’ imagery of microfossils. Systems 
automating both photography and focus stacking for high-
resolution imagery exist (Chen et  al., 2019), but they are 
expensive and ideal for digitization of material from archi-
val collections (Thorpe and Zimmerman, 2019). A study 
by Miller et al. (2015) described a cost-effective technique 
for photographing conodont fossils using a petrographic 
microscope. Here, we present a similar method developed 
using free and simple software and a standard laboratory 
optical microscope/camera setup. The material used for 
demonstration below includes mixed benthic foraminifera 
sampled for radiocarbon dating from archival sediment 
core 90031-0061PC (Thibaudeau and Currie, 1991) held in 
the GSC-Atlantic Marine Geoscience Collection (core data 
are available from the NRCan expedition database: https://
ed.marine-geo.canada.ca/cruises_e.php).

METHODOLOGY

Preparing samples
Selected subsamples from the 90031-0061PC core were 

wet-sieved to greater than 150, 125, and 63  µm fractions 
and dried on filter paper. A fine-tipped paint brush was 
used to isolate microfossils from sediment on picking trays. 
Representative microfossils were picked for photogra-
phy. Each microfossil was centred on a tray with a black 
background.

Acquiring images
Images in this technical note were acquired on a Zeiss 

Axio Scope A1™ in reflected light brightfield configuration 
using the Zeiss Axiocam 512™ colour camera with 1× lens 
magnification and variable objective focus (10–20×). The 
Axiocam captures all images to a proprietary RAW .czi file, 
which can be exported to TIFFs while preserving most of 
the important image metadata. The Zeiss microscope comes 
with free software, ZEN lite™, which is used for acquisition 
and exportation (ZEN lite is available at https://www.zeiss.
com/microscopy/en/products/software/zeiss-zen-lite.html). 

To acquire imagery, first align the microfossil on a pho-
tography tray, ensuring that key features for identification 
(such as the aperture of the foraminifer) are facing up. Next, 
focus and centre the sample under the microscope. Launch 
the ZEN lite software. The workflow for photo acquisition is 
shown in Figures 1 and 2. Turn on ‘Live View’ (red label 1 
in Fig. 1) and ensure that the microfossil is centred under the 
camera. Adjust the ‘Microscope Components’ setting (label 
2) to match the camera model and the objective focus that the 
microfossil is being viewed under. Under the ‘Camera’ set-
ting, set ‘White Balance’ to ‘Auto’ (label 3). For file saving, 
set up a directory folder under ‘Tools’ > ‘Options’ > ‘Saving’ 
and select the destination path for the files to be written to. 
Once the edge of the specimen is brought into focus, make 
note of the tick mark that corresponds to the fine-focus dial 
position (edge). Next, bring the very top of the specimen 
into focus and make note of the fine-focus value (top). The 
difference between these two readings will be the number 
of pictures needed: each picture will be taken with the lens 
4 µm closer to the stage (one increment on the fine-focus 
drive, Fig. 2) than the previous focal depth. The focal depth 
slices will define components of the Z-stack for the compos-
ite image (Fig. 3).To acquire the first image of the stack, start 
with the very bottom edge of the microfossil in focus and 
click the ‘Snap’ button in ZEN lite (label 4 in Fig. 1). Turn 
the dial counterclockwise, moving to the next fine-focus 
increment. Repeat this process until the top of the sample 
is reached. For microfossils without significant relief, twice 
as many focal depths (photos at half-increments) may be  
necessary within the same fine-focus drive distance.

https://ed.marine-geo.canada.ca/cruises_e.php
https://ed.marine-geo.canada.ca/cruises_e.php
https://www.zeiss.com/microscopy/en/products/software/zeiss-zen-lite.html
https://www.zeiss.com/microscopy/en/products/software/zeiss-zen-lite.html
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Exporting .czi files to TIFFs
A batch export of .czi files can be completed in the ZEN 

lite (3.6) software, detailed in Figure  4. Select RAW files 
under ‘Processing’ (red label 1 in Fig. 4) > ‘Batch’ (label 2) 
> ‘+Add…’ (label 3) and then assign the folder directory. 
To assign the batch export parameters select ‘Batch Method’ 
(label 4) > ‘Image Export’ > ‘Parameters.’ Additional set-
tings are visible under ‘Show All’ (label 5) in the top right of 
the ‘Parameters’ field. Create a name for the export parame-
ters (label 6). For recommended settings, select ‘File Type’ > 
‘TIFF’ (label 7), select ‘Original Data’ (label 8), and unselect 
‘Create Folder’ (label 9). It is easiest to save the files to the 
same folder by selecting ‘Use Input Folder as Output Folder’ 
(label 10). By default, these parameters will only be edited 
for a single image and will need to be assigned to the other 
images in the listing. Select the image from the listing and 
select ‘Copy Parameters’ (label 11) and highlight the rest of 
the image list by checking the ‘Select All’ box (label 12) in 
the top left of the ‘Batch Processing’ window. Select ‘Paste 
Parameters’ (label 13) and click ‘Run Selected’ (label 14) to 

execute the batch export. Note that photos acquired using a 
microscope other than a Zeiss can still be batch exported in 
the TIFFs through the Zen lite software.

Focus stacking
Focus stacking can be done using a variety of software. 

For this note, Teledyne Lumenera Infinity Analyze  7™ 
(available at https://www.lumenera.com/support/microscopy/
drivers-downloads.html) and ImageJ (Fiji) (Schindelin et al., 
2012) using the Extended_Depth_Field.jar (Forster et  al., 
2004) plugin (from http://bigwww.epfl.ch/demo/edf/) were 
used. Note: the former is freeware; the latter is open source. 
The Infinity Analyze software has a user-friendly interface 
with an efficient workflow; however, sharper results have 
been produced from using ImageJ.

Focus stacking in Infinity Analyze 7
Focus stacking is highlighted in Figures 5 and 6. Open 

up the TIFFs using ‘File’ > ‘Open’ and select the direc-
tory for the folder with the images. Once all the images 
are loaded into Infinity Analyze, locate the focus stacking 
tool: ‘Combine’ > ‘Focus Stacking’ (red label 1 in Fig. 5). A 
prompt window will open with all the files available in the 
bottom pane. Select all these images and drag and drop them 
into the ‘Focus Stack’ pane (label 2). Keep all default set-
tings and hit ‘Preview’ (label 3). This will generate a stacked 

Figure 1.  ZEN lite (3.6) image acquisition workflow.

Figure 2.  Zeiss Axio Scope microscope fine-focus dial, indicating 
drive direction for increasing the height of focus. Photograph by 
C. Greaves. NRCan photo 2022-445

https://www.lumenera.com/support/microscopy/drivers-downloads.html
https://www.lumenera.com/support/microscopy/drivers-downloads.html
http://bigwww.epfl.ch/demo/edf/
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Figure 4.  Workflow for exporting .czi files to TIFFs in ZEN lite (3.6).

Figure 3.  Illustration of focal-depth increments (Z-slices) in relation to the microfossil, showing the fine-focus for 
the edge on the left and the fine-focus for the top on the right. Each tick mark increment represents a fine-focus 
value for photo acquisition.
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Figure 5.  Focus stacking workflow for Infinity Analyze 7.

Figure 6.  Image adjustments for focus-stacked image in Infinity Analyze 7.



6 C. Greaves and J.B.R. EamerTechnical Note 11

image, and if results are satisfactory, select ‘Keep’ (label 4). 
The generated image will be a bit blurry and require 
adjustment. Under ‘Adjust,’ select ‘Brightness / Contrast / 
Gamma’; recommended settings used in this note for sharp 
images are ‘Brightness’ = −50 to −40, ‘Contrast’ = 50 to 65, 
and ‘Gamma’ = 1.00 to 1.20 (Fig. 6). Important note: other 
image processing tools can be found under ‘Enhance,’ but 
these should only be used with careful consideration, as they 
change the data of the original image.

Focus stacking in ImageJ (Fiji) with TIFFs
To start, install the plugin Extended_Depth_Field.jar 

into ImageJ by opening the folder with the installation of 
ImageJ. Under the folder named ‘Plugins,’ drag and drop 
the Extended_Depth_Field.jar plugin and restart ImageJ to 
ensure the installation takes effect. To generate a stack in 
ImageJ, go into ‘File’ > ‘Import’ > ‘Image Sequence.’ In the 
‘Import Image Sequence’ window, select ‘RGB’ (red-green-
blue) image type and keep the other default settings. ImageJ 
will assemble these photos into a stack; image stacking may 
take a few minutes to complete, depending on available 
memory on the computer. Once finished, type ‘EDF’ in the 
ImageJ search bar, which will result in ‘EDF Easy Mode’ 
becoming available under the ‘Commands’ line. Select this 
and click ‘Run.’ Accept the defaults of this tool (Fig.  5) 
and run it, which may take a few minutes. After the focus-
stacked image is finished, it can be fine-tuned under ‘Image’ 
> ‘Adjust’ > ‘Brightness/Contrast’ (Fig.  5). The sharpest 
images can be created by lining up the slope of the line with 
the histogram maxima. Once set, save the focus-stacked 
image as a TIFF under ‘File’ > ‘Save As’ > ‘Tif.’

Focus stacking in ImageJ (Fiji) with  
RAW .czi files

Install the plugin Extended_Depth_Field.jar in the 
ImageJ plugin folder (as described above) and ensure that 
your current version of ImageJ has Bio-Formats installed. If 
not, you will have to install it (available at https://www.openmi-
croscopy.org/bio-formats/downloads/). This is the same process 
as for the EDF plugin. To stack the .czi images, type ‘Bio-
Formats’ in the search bar and select ‘Bio-Format Importer’ 
under the ‘Commands’ tab. Run the command, and you will 
be prompted with a file directory. Choose the folder where 
the .czi files can be found and select ‘OK.’ An additional 
window will open, ‘Bio-Formats Import Options,’ for which 
the following options should be selected: under ‘Stack view-
ing’ select ‘Hyperstack’; under ‘Dataset organization’ select 
‘Group files with similar names,’ and under ‘Colour options’ 
select ‘Composite.’ Accept all other defaults and press ‘OK.’ 
The program will assemble a hyperstack and will split the 
colour channels into RGB, which multiplies the photo stack 
by three. Once the stack is loaded, select ‘Image’ > ‘Colour’ 
> ‘Stack to RGB,’ which will merge the colour channels 

back to a composite colour image. Under the search tab, type 
‘EDF’ and run the ‘EDF Easy Mode’ command and click 
‘Run.’ A prompt will open with a ‘Speed/Quality’ slider and 
a height-map regulator (‘Height-map reg.’) slider. Accept 
the defaults and click ‘Run,’ which may take a few minutes 
(Fig. 7). After the focus-stacked image is finished, fine-tune 
it under ‘Image’ > ‘Adjust’ > ‘Brightness/Contrast.’ The 
sharpest images usually will be found by aligning the slope 
of the line with the histogram maxima (Fig.  8). Once set, 
save the focus-stacked image as a TIFF under ‘File’ > ‘Save 
As’ > ‘Tif.’

Annotating

Determining scale
Most microscope cameras should have a system that 

writes the scaling metadata onto the image in the acquisi-
tion software. Resolution tends to be expressed in pixels per 
inch for general photography; however, scientific photogra-
phy will report resolution in pixels per micron. To check the 
resolution of an image in ImageJ, open one photo from the 
stack and select ‘Image’ > ‘Show Info’ (Fig. 9).

Setting scale
In ImageJ search for ‘Set Scale’ and run the command. A 

window prompt (Fig. 10) will ask for the distance in pixels 
per known unit of length; microns can also be entered as 
micrometres (μm). The aspect ratio should always be left 
as 1.0; to keep the scaling the same for all images select 
‘Global.’

Adding scale bar
In ImageJ search for ‘Scale Bar’ and run the command 

(Fig. 11). The default scale bar is horizontal, and the length 
can be defined in microns. All adjustments can be seen on 
the image. Recommended settings used in this technical note 
for 0.16  microns/pixel resolution is 200  µm width, a line 
thickness of 25 pixels, and a font size of 100. All annota-
tions can be permanently fixed to the image by unselecting 
the ‘Overlay’ option. This will allow the scale bar to be seen 
outside of a technical image viewer such as ImageJ. To save 
the final image select ‘File’ > ‘Save As’ > ‘Tif’ (Fig. 12). For 
compressed copies of the base file, export to JPEGs.

CONCLUSION
Photographing microfossils at varying focal depths 

is a rapid, inexpensive process that uses focus stacking to 
develop high-resolution images. The process can be subdi-
vided into image acquisition, exportation, focus stacking, 
and annotation.

https://www.openmicroscopy.org/bio-formats/downloads/
https://www.openmicroscopy.org/bio-formats/downloads/
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Figure 7.  Focus stacking using Extended_Depth_Field.jar plugin.

Figure 8.  Image adjustment of 
brightness and contrast in ImageJ.

Figure 9.  ImageJ image information tab with image resolution 
entry highlighted.

Figure 10.  ImageJ ‘Set Scale’ command configuration 
window.
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Figure 11.  ImageJ ‘Scale Bar’ 
window.

Figure 12.  From top to bottom: focus-stacked images (focus stacks) using Infinity Analyze 7, focus stacks using TIFF exports in 
ImageJ, and focus stacks using RAW .czi files. Both stacks in ImageJ used the Extended_Depth_Field.jar plugin (Forster et al., 2004). 
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The acquisition process consists of capturing photos at  
4 µm fine-focus increments from bottom to top, each of 
which has focused slices of the fossil. To maintain image 
fidelity, it is key to batch export these images into an uncom-
pressed file format (.czi or TIFF was used in this note). Once 
exported, these images can be assembled into a Z-stack, 
where they can be algorithmically assembled into a com-
posite image using focus-stacking software (e.g. ImageJ or 
Infinity Analyze). Lastly, photo viewer application tools can 
be used to display annotated information, such as a scale bar, 
on the image.

The procedure highlighted in this technical note will 
allow researchers to more easily share valuable informa-
tion that is rich in detail to better communicate and answer  
questions relating to paleoenvironment, paleogeography, 
and paleoecology.

ACKNOWLEDGMENTS
This manuscript benefited greatly from peer review by 

Alexandre Normandeau and Lynn Dafoe, GSC-Atlantic. 
Assistance in the laboratory was provided by Kimberley 
Jenner, Kate Jarrett, and Lori Campbell. Funding for this 
work was provided by Natural Resources Canada’s Marine 
Geoscience for Marine Spatial Planning program.

REFERENCES
Bohaty, S.M., Zachos, J.C., and Delaney, M.L., 2012. 

Foraminiferal Ca/Mg evidence for Southern Ocean cooling 
across the Eocene–Oligocene transition; Earth and Planetary 
Science Letters, v. 317-318, p. 251–261. https://doi.
org/10.1016/j.epsl.2011.11.037

Bradley, L.R., Marret, F., Mudie, P.J., Aksu, A.E., and 
Hiscott, R.N., 2012. Constraining Holocene sea-surface 
conditions in the south-western Black Sea using dinoflagellate 
cysts; Journal of Quaternary Science, v. 27, no. 8, p. 835–843. 
https://doi.org/10.1002/jqs.2580

Chen, C., Chen, P.-C., Jang, J.-P., Hsu, Y.-C., and Wang, C.-C., 
2019. Development of an auto focusing stacker for 
photomicrography of marine microorganisms; in Proceedings, 
2019 IEEE Underwater Technology (UT), Kaohsiung, 
Taiwan, April 16–19, 2019; p. 1–5. https://doi.org/10.1109/
UT.2019.8734300

Fensome, R.A., Williams, G.L., Wood, S.E.L., and Riding, J.B., 
2019. A review of the areoligeracean dinoflagellate cyst 
Cyclonephelium and morphologically similar genera; 
Palynology, v. 43, Supp. 1, p. 1–71. https://doi.org/10.1080/01
916122.2019.1596391

Forster, B., Van De Ville, D., Berent, J., Sage, D., and Unser, M., 
2004. Complex wavelets for extended depth-of-field: a new 
method for the fusion of multichannel microscopy images; 
Microscopy Research and Technique, v. 65, no. 1-2, p. 33–42. 
https://doi.org/10.1002/jemt.20092

Kibby, G., 2019. Focus stacking in macrophotography and 
microphotography; Field Mycology: a Magazine for the Study 
and Identification of Wild Fungi, v. 20, no. 2, p. 51–54. https://
doi.org/10.1016/j.fldmyc.2019.03.013

Lister, C.J., Hiscott, R.N., Aksu, A.E., and Mudie, P.J., 2015. 
Compositional trends through the Holocene mud succession of 
the southwestern Black Sea shelf: implications for sedimentary 
provenance and water-level history; Sedimentary Geology, 
v. 316, p. 13–25. https://doi.org/10.1016/j.sedgeo.2014.11.004

Miller, J.F., Dattilo, B.F., Ethington, R.L., and Freeman, R.L., 
2015. Polyfocal photography of conodonts and other 
microfossils using petrographic microscopes; Annales 
de Paléontologie, v. 101, no. 3, p. 179–184. https://doi.
org/10.1016/j.annpal.2015.04.003

Mudie, P.J. and Yanko-Hombach, V., 2019. Microforaminiferal 
linings as proxies for paleosalinity and pollution: Danube 
Delta example; Micropaleontology, v. 65, no. 1, p. 27–45. 
https://doi.org/10.47894/mpal.65.1.02

Pieńkowski, A.J., England, J.H., Furze, M.F.A., Blasco, S., 
Mudie, P.J., and MacLean, B., 2013. 11,000yrs of 
environmental change in the Northwest Passage: a multiproxy 
core record from central Parry Channel, Canadian High Arctic; 
Marine Geology, v. 341, p. 68–85. https://doi.org/10.1016/j.
margeo.2013.04.008

Schindelin, J., Arganda-Carreras, I., Frise, E., Kaynig, V., 
Longair, M., Pietzsch, T., … Tomancak, P., 2012. Fiji: an 
open-source platform for biological-image analysis; Nature 
Methods, v. 9, no. 7, p. 676–682. https://doi.org/10.1038/
nmeth.2019

Sutton, M.D., 2008. Tomographic techniques for the study of 
exceptionally preserved fossils; Proceedings of the Royal 
Society B: Biological Sciences, v. 275, no. 1643,  
p. 1587–1593. https://doi.org/10.1098/rspb.2008.0263

Thibaudeau, S. and Currie, R., 1991. CSS Hudson cruise 90031; 
Geological Survey of Canada, Open File 2426, 153 p. https://
doi.org/10.4095/132671

Thorpe, E.D. and Zimmerman, A.N., 2019. Bringing microfossil 
specimens into the light: using semi-automated digitization 
techniques to improve collection accessibility; in Making the 
case for natural history collections, Proceedings of the Society 
for the Preservation of Natural History Collections 34th 
Annual Meeting, Chicago, Illinois, May 25–31, 2019; p. 202.

Witkowski, J., Edgar, K., Harding, I., McCartney, K., and 
Bąk, M., 2015. Marine microfossils; in Encyclopedia of 
marine geosciences, (ed.) J. Harff, M. Meschede, S. Petersen, 
and J. Thiede; Springer, Dordrecht, Netherlands, 12 p. https://
doi.org/10.1007/978-94-007-6644-0_73-1

https://doi.org/10.1016/j.epsl.2011.11.037
https://doi.org/10.1016/j.epsl.2011.11.037
https://doi.org/10.1002/jqs.2580
https://doi.org/10.1109/UT.2019.8734300
https://doi.org/10.1109/UT.2019.8734300
https://doi.org/10.1080/01916122.2019.1596391
https://doi.org/10.1080/01916122.2019.1596391
https://doi.org/10.1002/jemt.20092
https://doi.org/10.1016/j.fldmyc.2019.03.013
https://doi.org/10.1016/j.fldmyc.2019.03.013
https://doi.org/10.1016/j.sedgeo.2014.11.004
https://doi.org/10.1016/j.annpal.2015.04.003
https://doi.org/10.1016/j.annpal.2015.04.003
https://doi.org/10.47894/mpal.65.1.02
https://doi.org/10.1016/j.margeo.2013.04.008
https://doi.org/10.1016/j.margeo.2013.04.008
https://doi.org/10.1038/nmeth.2019
https://doi.org/10.1038/nmeth.2019
https://doi.org/10.1098/rspb.2008.0263
https://doi.org/10.4095/132671
https://doi.org/10.4095/132671
https://doi.org/10.1007/978-94-007-6644-0_73-1
https://doi.org/10.1007/978-94-007-6644-0_73-1

	Abstract
	Résumé
	INTRODUCTION
	METHODOLOGY
	Preparing samples
	Acquiring images
	Exporting .czi files to TIFFs
	Focus stacking
	Focus stacking in Infinity Analyze 7
	Focus stacking in ImageJ (Fiji) with TIFFs
	Focus stacking in ImageJ (Fiji) with 
RAW .czi files

	Annotating
	Determining scale
	Setting scale
	Adding scale bar


	CONCLUSION
	ACKNOWLEDGMENTS
	REFERENCES
	Illustrations
	Figure 1
	Figure 2
	Figure 3
	Figure 4
	Figure 5
	Figure 6
	Figure 7
	Figure 8
	Figure 9
	Figure 10
	Figure 11
	Figure 12




